<!DOCTYPE html>
<html class="no-js mh-layout-1 mh-large mh-one-sb" lang="en-US" xmlns:og="http://ogp.me/ns#" xmlns:fb="http://ogp.me/ns/fb#">
<head>
<meta charset="UTF-8">
<title>Rock On The Range Returns! - hardrockhaven.net</title>
<link rel="stylesheet" href="http://fonts.googleapis.com/css?family=Nobile|Roboto+Condensed:300,400,700">
<link rel="stylesheet" href="http://hardrockhaven.net/online/wp-content/themes/mh_magazine/style.css" media="screen">
<meta name="description" content="Rock On The Range Returns!" />
<meta name="keywords" content="Rock On The Range Returns, 2017, Metallica, Volbeat, Primus, The Pretty Reckless, Korn, The Offspring, Papa Roach, Seether, Soundgarden, +LIVE+, Chevelle, Bush, Pierce The Veil, Gojira, Sum 41, Of Mice &amp; Men" />
<link rel="shortcut icon" href="http://hardrockhaven.net/online/wp-content/uploads/2013/10/favicon.ico">
<!--[if lt IE 9]>
<script src="http://css3-mediaqueries-js.googlecode.com/svn/trunk/css3-mediaqueries.js"></script>
<![endif]-->
<meta name="viewport" content="width=device-width; initial-scale=1.0">
<link rel="pingback" href="http://hardrockhaven.net/online/xmlrpc.php"/>
<!--[if IE 7]><link rel='stylesheet' id='css-ie-fix' href='http://hardrockhaven.net/online/wp-content/plugins/special-recent-posts-pro/assets/css/css-ie7-fix.css' type='text/css' media='all' /> <![endif]--><link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//code.jquery.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="hardrockhaven.net &raquo; Feed" href="http://hardrockhaven.net/online/feed/" />
<link rel="alternate" type="application/rss+xml" title="hardrockhaven.net &raquo; Comments Feed" href="http://hardrockhaven.net/online/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/hardrockhaven.net\/online\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='batch_css-css'  href='http://hardrockhaven.net/online/wp-content/plugins/batchmove/css/batch.css?ver=4.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='usr-style-css'  href='http://hardrockhaven.net/online/wp-content/plugins/universal-star-rating/includes/usr_style.php?px=16&#038;usrver=1.10.3&#038;ver=4.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='srp-front-stylesheet-css'  href='http://hardrockhaven.net/online/wp-content/plugins/special-recent-posts-pro/assets/css/css-front.css?ver=4.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_frontend-css'  href='http://hardrockhaven.net/online/wp-content/plugins/photo-gallery/css/bwg_frontend.css?ver=1.3.33' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_font-awesome-css'  href='http://hardrockhaven.net/online/wp-content/plugins/photo-gallery/css/font-awesome/font-awesome.css?ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_mCustomScrollbar-css'  href='http://hardrockhaven.net/online/wp-content/plugins/photo-gallery/css/jquery.mCustomScrollbar.css?ver=1.3.33' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_sumoselect-css'  href='http://hardrockhaven.net/online/wp-content/plugins/photo-gallery/css/sumoselect.css?ver=3.0.2' type='text/css' media='all' />
<script type='text/javascript' src='http://hardrockhaven.net/online/wp-content/plugins/batchmove/js/batch.js?ver=4.7.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"http:\/\/hardrockhaven.net\/online\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://hardrockhaven.net/online/wp-content/plugins/adrotate/library/jquery.adrotate.dyngroup.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"http:\/\/hardrockhaven.net\/online\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://hardrockhaven.net/online/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='http://hardrockhaven.net/online/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://hardrockhaven.net/online/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://hardrockhaven.net/online/wp-content/plugins/photo-gallery/js/bwg_frontend.js?ver=1.3.33'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var bwg_objectsL10n = {"bwg_select_tag":"Select Tag","bwg_search":"Search"};
/* ]]> */
</script>
<script type='text/javascript' src='http://hardrockhaven.net/online/wp-content/plugins/photo-gallery/js/jquery.sumoselect.min.js?ver=3.0.2'></script>
<script type='text/javascript' src='http://hardrockhaven.net/online/wp-content/plugins/photo-gallery/js/jquery.mobile.js?ver=1.3.33'></script>
<script type='text/javascript' src='http://hardrockhaven.net/online/wp-content/plugins/photo-gallery/js/jquery.mCustomScrollbar.concat.min.js?ver=1.3.33'></script>
<script type='text/javascript' src='http://hardrockhaven.net/online/wp-content/plugins/photo-gallery/js/jquery.fullscreen-0.4.1.js?ver=0.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var bwg_objectL10n = {"bwg_field_required":"field is required.","bwg_mail_validation":"This is not a valid email address.","bwg_search_result":"There are no images matching your search."};
/* ]]> */
</script>
<script type='text/javascript' src='http://hardrockhaven.net/online/wp-content/plugins/photo-gallery/js/bwg_gallery_box.js?ver=1.3.33'></script>
<script type='text/javascript' src='http://code.jquery.com/jquery-migrate-1.2.1.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://hardrockhaven.net/online/wp-content/themes/mh_magazine/js/scripts.js?ver=4.7.3'></script>
<link rel='https://api.w.org/' href='http://hardrockhaven.net/online/wp-json/' />
<link rel='prev' title='Bobby &#8220;Blitz&#8221; Ellsworth of Overkill' href='http://hardrockhaven.net/online/2017/03/video-interview-bobby-blitz-ellsworth-of-overkill-2017/' />
<link rel="canonical" href="http://hardrockhaven.net/online/2017/03/rock-on-the-range-returns/" />
<link rel='shortlink' href='http://hardrockhaven.net/online/?p=54400' />
<link rel="alternate" type="application/json+oembed" href="http://hardrockhaven.net/online/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fhardrockhaven.net%2Fonline%2F2017%2F03%2Frock-on-the-range-returns%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://hardrockhaven.net/online/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fhardrockhaven.net%2Fonline%2F2017%2F03%2Frock-on-the-range-returns%2F&#038;format=xml" />

<!-- This site is using AdRotate v4.0 to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:1px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<!-- Graceful Pull-Quotes plugin v2.6.1 -->
	<link rel="stylesheet" href="http://hardrockhaven.net/online/wp-content/plugins/graceful-pull-quotes/resources/jspullquotes-core.css" type="text/css" />
	<link rel="stylesheet" href="http://hardrockhaven.net/online/wp-content/plugins/graceful-pull-quotes/styles/Default.css" type="text/css" />
	<script type="text/javascript">
		var jspq_options = new Array("1", "1", "right", "1", "1", "aside", "pullquote", "pullquote pqRight");
	</script>
	<script type="text/javascript" src="http://hardrockhaven.net/online/wp-content/plugins/graceful-pull-quotes/resources/jspullquotes.js"></script>
<!-- end pull-quote additions -->
<meta name="generator" content="NextGEN Gallery v2.2.1" />
<meta name="generator" content="NextGEN Gallery Optimizer Basic v2.1.5" />
   
    <style type="text/css">
    	    				h1, h2, h3, h4, h5, h6 { font-family: "Roboto Condensed", sans-serif; }
							body { font-family: "Nobile", sans-serif; }	
		    		
    		.header-wrap { background: #000000 }
    	    		
    		.wrapper { background: #111111 }
    	    	    		    		.main-nav, 
    		.header-nav .menu .menu-item:hover > .sub-menu,
    		.main-nav .menu .menu-item:hover > .sub-menu, 
    		.footer-nav .menu-item:hover,
    		.slide-caption,
    		.spotlight,
    		#carousel,
    		footer,
    		#commentform input#submit:hover,
    		#cancel-comment-reply-link:hover,
    		.wpcf7-submit:hover { background: #000000 }
    	    	    		    		.logo-desc,
    		.ticker-title,
    		.header-nav .menu-item:hover,
    		.main-nav li:hover,
    		.footer-nav,
    		.footer-nav .menu .menu-item:hover > .sub-menu,
    		.sl-caption,
    		.subheading,
    		.page-title,
    		.caption,
    		.page-numbers:hover,
    		.current,
    		.pagelink,
    		a:hover .pagelink,
    		#commentform input#submit,
    		#cancel-comment-reply-link,
    		.wpcf7-submit,
    		.post-tags li:hover,
    		.tagcloud a:hover { background: #a31000; }
    		.slide-caption,
    		#carousel,
    		.widget-title,
    		.footer-widget-title,
    		.author-box,
    		.cat-desc,
    		#author:hover,
    		#email:hover,
    		#url:hover,
    		#comment:hover,
    		blockquote { border-color: #a31000; }
    		a:hover,
    		.entry a:hover,
    		.slide-title:hover, 
    		.sl-title:hover,
    		.related-title:hover,
    		.dropcap { color: #a31000; }
    	    		
    		.news-ticker,
    		#searchform,
    		.author-box,
    		.cat-desc,
    		.post-nav-wrap,
    		#wp-calendar caption,
    		.no-comments,
    		#respond,
    		.wpcf7-form { background: #494949; }
    	    		
    		body { color: #e5a320; }
    	    	    		.logo-desc,
    		.header-nav .menu-item:hover a, 
    		.header-nav .sub-menu a,
    		.main-nav li a,
    		.footer-nav .menu-item:hover a, 
    		.footer-nav .sub-menu a,
    		.ticker-title,	
    		.subheading,
    		.page-title,
    		footer,
    		.sl-title,
    		.sl-caption,
    		.slide-caption,
    		.caption { color: #e5a320; }
    	    	    		.meta, .breadcrumb { color: #efca37; }
    	    	    		a, .entry a { color: #e59f14; }
    	    	.cat-desc { background: #111; }
.slide-title:hover { color: #e59f14; }

	</style> 
    <style type="text/css" id="custom-background-css">
body.custom-background { background-color: #000000; background-image: url("http://hardrockhaven.net/online/wp-content/uploads/2014/11/red-fire21.jpg"); background-position: center top; background-size: auto; background-repeat: no-repeat; background-attachment: fixed; }
</style>

<!-- START - Facebook Open Graph, Google+ and Twitter Card Tags 2.0.7 -->
 <!-- Facebook Open Graph -->
  <meta property="og:locale" content="en_US"/>
  <meta property="og:site_name" content="hardrockhaven.net"/>
  <meta property="og:title" content="Rock On The Range Returns!"/>
  <meta property="og:url" content="http://hardrockhaven.net/online/2017/03/rock-on-the-range-returns/"/>
  <meta property="og:type" content="article"/>
  <meta property="og:description" content="by Steve Patrick
-- Senior Columnist --



The biggest rock festival in the US will be entering its second decade in 2017. The 11th annual Rock On The Range will take place May 19th, 20th and 21st at MAPFRE Stadium in Columbus, OH. Rock On The Range is known for raising the bar each year and th"/>
  <meta property="og:image" content="http://hardrockhaven.net/online/wp-content/uploads/2017/03/Overkill_2017.jpg"/>
  <meta property="article:published_time" content="2017-03-27T20:31:57+00:00"/>
  <meta property="article:modified_time" content="2017-03-27T20:31:57+00:00" />
  <meta property="og:updated_time" content="2017-03-27T20:31:57+00:00" />
  <meta property="article:section" content="Main Articles"/>
  <meta property="article:publisher" content="https://www.facebook.com/HardrockHaven.net/"/>
  <meta property="fb:app_id" content="164933486909694"/>
 <!-- Google+ / Schema.org -->
  <meta itemprop="name" content="Rock On The Range Returns!"/>
  <meta itemprop="description" content="by Steve Patrick
-- Senior Columnist --



The biggest rock festival in the US will be entering its second decade in 2017. The 11th annual Rock On The Range will take place May 19th, 20th and 21st at MAPFRE Stadium in Columbus, OH. Rock On The Range is known for raising the bar each year and th"/>
  <meta itemprop="image" content="http://hardrockhaven.net/online/wp-content/uploads/2017/03/Overkill_2017.jpg"/>
 <!-- Twitter Cards -->
  <meta name="twitter:title" content="Rock On The Range Returns!"/>
  <meta name="twitter:url" content="http://hardrockhaven.net/online/2017/03/rock-on-the-range-returns/"/>
  <meta name="twitter:description" content="by Steve Patrick
-- Senior Columnist --



The biggest rock festival in the US will be entering its second decade in 2017. The 11th annual Rock On The Range will take place May 19th, 20th and 21st at MAPFRE Stadium in Columbus, OH. Rock On The Range is known for raising the bar each year and th"/>
  <meta name="twitter:image" content="http://hardrockhaven.net/online/wp-content/uploads/2017/03/Overkill_2017.jpg"/>
  <meta name="twitter:card" content="summary_large_image"/>
 <!-- SEO -->
 <!-- Misc. tags -->
<!-- END - Facebook Open Graph, Google+ and Twitter Card Tags 2.0.7 -->

</head>
<body id="mh-mobile" class="post-template-default single single-post postid-54400 single-format-standard custom-background"> 
<aside class="header-widget">
	<div class="sb-widget">			<div class="textwidget"><!-- Error, Ad is not available at this time due to schedule/geolocation restrictions! --></div>
		</div></aside>
<div class="container mh-mobile">
<header class="header-wrap">
		<div class="logo-wrap" role="banner">
<a href="http://hardrockhaven.net/online/" title="hardrockhaven.net" rel="home"><img src="http://hardrockhaven.net/online/wp-content/uploads/2014/11/HardrockHaven2014tolex.jpg" height="152" width="959" alt="hardrockhaven.net" /></a>
</div>
	<nav class="main-nav clearfix">
		<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-32463" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-32463"><a href="http://hardrockhaven.net/online/">Home</a></li>
<li id="menu-item-32459" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32459"><a href="http://hardrockhaven.net/online/featured-articles/">Articles</a></li>
<li id="menu-item-32460" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32460"><a href="http://hardrockhaven.net/online/concert-reviews/">Concert Reviews</a></li>
<li id="menu-item-48133" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48133"><a href="http://hardrockhaven.net/online/category/gear-reviews/">Gear</a></li>
<li id="menu-item-32461" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32461"><a href="http://hardrockhaven.net/online/interviews/">Interviews</a></li>
<li id="menu-item-32462" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-32462"><a href="http://hardrockhaven.net/online/music-reviews/">Music Reviews</a>
<ul class="sub-menu">
	<li id="menu-item-48539" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48539"><a href="http://hardrockhaven.net/online/category/music-reviews/1980-landmark-albums-turn-35/">1980: Landmark Albums Turn 35</a></li>
	<li id="menu-item-53838" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53838"><a href="http://hardrockhaven.net/online/category/music-reviews/reviews-revisisted/">Revisited</a></li>
</ul>
</li>
<li id="menu-item-32507" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32507"><a href="http://hardrockhaven.net/online/category/news-wires/">The PR Wires</a></li>
<li id="menu-item-41874" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41874"><a href="http://hardrockhaven.net/online/the-lists/">The Lists</a></li>
</ul></div>	</nav>
</header>
<section class="news-ticker clearfix">
	<div class="ticker-title">Hot off the Press</div>
	<div class="ticker-content">
		<ul id="ticker">
		    		<li><a href="http://hardrockhaven.net/online/2017/03/rock-on-the-range-returns/"><span class="meta">March 27, 2017 in Main Articles // </span>Rock On The Range Returns!</a></li>
    	    		<li><a href="http://hardrockhaven.net/online/2017/03/video-interview-bobby-blitz-ellsworth-of-overkill-2017/"><span class="meta">March 19, 2017 in Featured // </span>Bobby &#8220;Blitz&#8221; Ellsworth of Overkill</a></li>
    	    		<li><a href="http://hardrockhaven.net/online/2017/03/interview-with-punk-rock-barbie-2017/"><span class="meta">March 19, 2017 in Interviews // </span>Punk Rock Barbie</a></li>
    	    		<li><a href="http://hardrockhaven.net/online/2017/03/letters-from-the-fire-worth-the-pain-music-reviews/"><span class="meta">March 18, 2017 in Music Reviews // </span>Letters From The Fire | Worth The Pain</a></li>
    	    		<li><a href="http://hardrockhaven.net/online/2017/03/future-villains-release-new-single-back-to-hell/"><span class="meta">March 17, 2017 in The PR Wires // </span>Future Villains Release New Single &#8220;Back to Hell&#8221;</a></li>
    	    		<li><a href="http://hardrockhaven.net/online/2017/03/audio-interview-with-kelly-ogden-of-the-dollyrots/"><span class="meta">March 15, 2017 in Featured // </span>Kelly Ogden of The Dollyrots</a></li>
    	    		<li><a href="http://hardrockhaven.net/online/2017/03/chris-bickley-digital-reflection-music-review/"><span class="meta">March 14, 2017 in Music Reviews // </span>Chris Bickley | Digital Reflection</a></li>
    	    		<li><a href="http://hardrockhaven.net/online/2017/03/vescera-beyond-the-fight-music-review/"><span class="meta">March 14, 2017 in Music Reviews // </span>Vescera | Beyond The Fight</a></li>
    	    		<li><a href="http://hardrockhaven.net/online/2017/03/live-aesthetic-perfection-concert-review-photo-gallery/"><span class="meta">March 13, 2017 in Concert Reviews // </span>LIVE! | Aesthetic Perfection</a></li>
    	    		<li><a href="http://hardrockhaven.net/online/2017/03/michael-schenker-fest-live-tokyo-international-forum-hall-review/"><span class="meta">March 12, 2017 in Music Reviews // </span>Michael Schenker Fest: Live Tokyo International Forum Hall</a></li>
    		    </ul>
	</div>
</section>
<div class="wrapper clearfix">
	<div class="main">
				<div class="content left"><article class="post-54400 post type-post status-publish format-standard has-post-thumbnail hentry category-main-articles tag-12150 tag-bush tag-chevelle tag-gojira tag-korn tag-live tag-metallica tag-of-mice-men tag-papa-roach tag-pierce-the-veil tag-primus tag-rock-on-the-range-returns tag-seether tag-soundgarden tag-sum-41 tag-the-offspring tag-the-pretty-reckless tag-volbeat">
	<header class="post-header">			
		<h1 class="entry-title">Rock On The Range Returns!</h1>
					
	</header>
		<div class="entry clearfix"><blockquote><p><span style="text-decoration: underline;">by Steve Patrick</span><br />
&#8212; Senior Columnist &#8212;</p></blockquote>
<p><img src="http://hardrockhaven.net/online/wp-content/uploads/2017/03/logo_2017.png" alt="" width="1400" height="634" class="aligncenter size-full wp-image-54405" srcset="http://hardrockhaven.net/online/wp-content/uploads/2017/03/logo_2017.png 1400w, http://hardrockhaven.net/online/wp-content/uploads/2017/03/logo_2017-350x159.png 350w, http://hardrockhaven.net/online/wp-content/uploads/2017/03/logo_2017-768x348.png 768w, http://hardrockhaven.net/online/wp-content/uploads/2017/03/logo_2017-500x226.png 500w" sizes="(max-width: 1400px) 100vw, 1400px" /></p>
<p><img src="http://hardrockhaven.net/online/wp-content/uploads/2017/03/korn-12-350x233.jpg" alt="" width="350" height="233" class="alignright size-medium wp-image-54409" srcset="http://hardrockhaven.net/online/wp-content/uploads/2017/03/korn-12-350x233.jpg 350w, http://hardrockhaven.net/online/wp-content/uploads/2017/03/korn-12-500x333.jpg 500w, http://hardrockhaven.net/online/wp-content/uploads/2017/03/korn-12.jpg 640w" sizes="(max-width: 350px) 100vw, 350px" />The biggest rock festival in the US will be entering its second decade in 2017. The 11th annual Rock On The Range will take place May 19th, 20th and 21st at MAPFRE Stadium in Columbus, OH. Rock On The Range is known for raising the bar each year and this one is no exception. Thrash metal forefathers Metallica are the big addition this year and are sure to make this year’s Rock On The Range an unforgettable experience.</p>
<p>As soon as their presence on the bill was announced, Metallica’s factor was clearly visible. Tickets for Rock On The Range sold out in record time, just over one month after going on sale, marking the fifth consecutive advance sellout for the festival.</p>
<p>Metallica will be headlining the festival on Sunday night with Soundgarden and Korn headlining Friday and Saturday respectively. In addition to the music entertainment, Rock On The Range also offers the Rolling Rock Comedy Tent. The tent will feature sets from nationally known comedians plus Columbus’ top comedy talent.</p>
<p><img src="http://hardrockhaven.net/online/wp-content/uploads/2017/03/stone-sour-6-350x230.jpg" alt="" width="350" height="230" class="alignleft size-medium wp-image-54411" srcset="http://hardrockhaven.net/online/wp-content/uploads/2017/03/stone-sour-6-350x230.jpg 350w, http://hardrockhaven.net/online/wp-content/uploads/2017/03/stone-sour-6-500x328.jpg 500w, http://hardrockhaven.net/online/wp-content/uploads/2017/03/stone-sour-6.jpg 640w" sizes="(max-width: 350px) 100vw, 350px" />As if three full days of balls-to-the-wall rock wasn’t enough, there will also be a Rock On The Range official festival kick-off party featuring Stone Sour on Thursday, May 18th at Express Live! in Columbus. This intimate gig will mark Stone Sour’s first show in support of Hydrograd, their brand new album coming out later this summer.</p>
<p>The daily band lineup for Rock On The Range is as follows:</p>
<p>Friday, May 19: Soundgarden, +LIVE+, Chevelle, Bush, Pierce The Veil, Gojira, Sum 41, Of Mice &#038; Men, Thrice, Motionless In White, Beartooth, The Amity Affliction, I Prevail, Red Fang, Bleeker, Norma Jean, Badflower, Goodbye June, Cover Your Tracks, Aeges</p>
<p>Saturday, May 20: Korn, The Offspring, Papa Roach, Seether, Coheed and Cambria, Taking Back Sunday, Alter Bridge, Skillet, In Flames, Starset, The Story So Far, Turnstile, Whitechapel, Attila, Frank Carter &#038; The Rattlesnakes, Kyng, DED, Sylar, Fire From The Gods, One Less Reason</p>
<p>Sunday, May 21: Metallica, Volbeat, Primus, The Pretty Reckless, Biffy Clyro, Amon Amarth, The Dillinger Escape Plan, Nothing More, Zakk Sabbath, Rival Sons, Deafheaven, Suicide Silence, Every Time I Die, Dinosaur Pile-Up, Dorothy, Radkey, Wage War, As Lions, Royal Republic, Mother Feather</p>
<p>Rock On The Range is produced by Danny Wimmer Presents, AEG Live, and MAPFRE Stadium.</p>
<p>Rock On The Range is supported by the following sponsors: Monster Energy, Bud Light, Jack Daniel’s and Zippo. These partners, along with many others, will feature interactive experiences, artist meet &#038; greets, and other unique fan engagement opportunities throughout the festival.</p>
<p><img src="http://hardrockhaven.net/online/wp-content/uploads/2017/03/ROTR2017poster.jpg" alt="" width="475" height="735" class="aligncenter size-full wp-image-54407" srcset="http://hardrockhaven.net/online/wp-content/uploads/2017/03/ROTR2017poster.jpg 475w, http://hardrockhaven.net/online/wp-content/uploads/2017/03/ROTR2017poster-226x350.jpg 226w" sizes="(max-width: 475px) 100vw, 475px" /></p>
<p>Website: <a href="http://www.RockOnTheRange.com" target="_blank">www.RockOnTheRange.com</a><br />
Facebook: <a href="http://www.twitter.com/rockontherange" target="_blank">www.facebook.com/rockontherange</a><br />
Twitter: <a href="http://www.twitter.com/rockontherange" target="_blank">www.twitter.com/rockontherange</a><br />
Instagram: <a href="http://www.instagram.com/rockontherange" target="_blank">www.instagram.com/rockontherange</a></p>
<p>[Photos appear courtesy of Chris A.]</p>
	</div>
	           
			<div class="post-tags clearfix">
        	<ul><li><a href="http://hardrockhaven.net/online/tag/2017/" rel="tag">2017</a></li><li><a href="http://hardrockhaven.net/online/tag/bush/" rel="tag">Bush</a></li><li><a href="http://hardrockhaven.net/online/tag/chevelle/" rel="tag">Chevelle</a></li><li><a href="http://hardrockhaven.net/online/tag/gojira/" rel="tag">Gojira</a></li><li><a href="http://hardrockhaven.net/online/tag/korn/" rel="tag">KoRn</a></li><li><a href="http://hardrockhaven.net/online/tag/live/" rel="tag">Live!</a></li><li><a href="http://hardrockhaven.net/online/tag/metallica/" rel="tag">Metallica</a></li><li><a href="http://hardrockhaven.net/online/tag/of-mice-men/" rel="tag">Of Mice &amp; Men</a></li><li><a href="http://hardrockhaven.net/online/tag/papa-roach/" rel="tag">Papa Roach</a></li><li><a href="http://hardrockhaven.net/online/tag/pierce-the-veil/" rel="tag">Pierce The Veil</a></li><li><a href="http://hardrockhaven.net/online/tag/primus/" rel="tag">Primus</a></li><li><a href="http://hardrockhaven.net/online/tag/rock-on-the-range-returns/" rel="tag">Rock On The Range Returns</a></li><li><a href="http://hardrockhaven.net/online/tag/seether/" rel="tag">Seether</a></li><li><a href="http://hardrockhaven.net/online/tag/soundgarden/" rel="tag">Soundgarden</a></li><li><a href="http://hardrockhaven.net/online/tag/sum-41/" rel="tag">Sum 41</a></li><li><a href="http://hardrockhaven.net/online/tag/the-offspring/" rel="tag">The Offspring</a></li><li><a href="http://hardrockhaven.net/online/tag/the-pretty-reckless/" rel="tag">The Pretty Reckless</a></li><li><a href="http://hardrockhaven.net/online/tag/volbeat/" rel="tag">Volbeat</a></li></ul>        </div>
		<div class="sb-widget posts-2">			<div class="textwidget"><img src="http://hardrockhaven.net/online/wp-content/uploads/2013/02/advertisement.png" alt="advertisement" width="75" height="7" class="alignleft size-full wp-image-26074" />

<br />

<center>
<div class="a-single a-84"><a href="http://chrisbickley.com/" target="blank"><img src="http://hardrockhaven.net/online/wp-content/uploads/2012/01/ChrisBickley2017.jpg" alt="" width="500" height="90" class="alignnone size-full wp-image-53960" /></a></div>
</center>
</div>
		</div>	
</article>
			<section class="share-buttons-container clearfix">
	    	<div class="share-button"><div class="fb-like" data-send="false" data-layout="button_count" data-width="450" data-show-faces="true" data-font="verdana"></div></div>
			<div class="share-button"><a href="https://twitter.com/share" class="twitter-share-button">Tweet</a></div>
			<div class="share-button"><div class="g-plusone" data-size="medium"></div></div>           	
		</section><nav class="section-title clearfix" role="navigation">
<div class="post-nav left">
<a href="http://hardrockhaven.net/online/2017/03/video-interview-bobby-blitz-ellsworth-of-overkill-2017/" rel="prev">&larr; Previous post</a></div>
<div class="post-nav right">
</div>
</nav>
<section class="related-posts">
<h3 class="section-title">Related Posts</h3>
<ul>
<li class="related-wrap clearfix">
<div class="related-thumb">
<a href="http://hardrockhaven.net/online/2017/01/ramblin-man-fair-announce-more-artists-extra-day/" title="Ramblin&#8217; Man Fair &#8211; Announce More Artists &#038; Extra Day!"><img width="70" height="53" src="http://hardrockhaven.net/online/wp-content/uploads/2017/01/Ramblin-Man-Fair-2017-70x53.jpg" class="attachment-cp_small size-cp_small wp-post-image" alt="" srcset="http://hardrockhaven.net/online/wp-content/uploads/2017/01/Ramblin-Man-Fair-2017-70x53.jpg 70w, http://hardrockhaven.net/online/wp-content/uploads/2017/01/Ramblin-Man-Fair-2017-174x131.jpg 174w, http://hardrockhaven.net/online/wp-content/uploads/2017/01/Ramblin-Man-Fair-2017-300x225.jpg 300w" sizes="(max-width: 70px) 100vw, 70px" /></a>
</div>
<div class="related-data">
<a href="http://hardrockhaven.net/online/2017/01/ramblin-man-fair-announce-more-artists-extra-day/"><h4 class="related-title">Ramblin&#8217; Man Fair &#8211; Announce More Artists &#038; Extra Day!</h4></a>
<span class="related-subheading"></span>
</div>
</li>
<li class="related-wrap clearfix">
<div class="related-thumb">
<a href="http://hardrockhaven.net/online/2013/12/live-halestorm-concert-photo-gallery/" title="LIVE! | Halestorm"><img width="70" height="53" src="http://hardrockhaven.net/online/wp-content/uploads/2013/12/HALESTORM-LIVE-featured-70x53.jpg" class="attachment-cp_small size-cp_small wp-post-image" alt="" srcset="http://hardrockhaven.net/online/wp-content/uploads/2013/12/HALESTORM-LIVE-featured-70x53.jpg 70w, http://hardrockhaven.net/online/wp-content/uploads/2013/12/HALESTORM-LIVE-featured-174x131.jpg 174w, http://hardrockhaven.net/online/wp-content/uploads/2013/12/HALESTORM-LIVE-featured-300x225.jpg 300w" sizes="(max-width: 70px) 100vw, 70px" /></a>
</div>
<div class="related-data">
<a href="http://hardrockhaven.net/online/2013/12/live-halestorm-concert-photo-gallery/"><h4 class="related-title">LIVE! | Halestorm</h4></a>
<span class="related-subheading"></span>
</div>
</li>
<li class="related-wrap clearfix">
<div class="related-thumb">
<a href="http://hardrockhaven.net/online/2015/11/live-the-birthday-massacre-concert-review-photo-gallery/" title="LIVE! | The Birthday Massacre"><img width="70" height="53" src="http://hardrockhaven.net/online/wp-content/uploads/2015/11/The-Birthday-Massacre-05-70x53.jpg" class="attachment-cp_small size-cp_small wp-post-image" alt="" srcset="http://hardrockhaven.net/online/wp-content/uploads/2015/11/The-Birthday-Massacre-05-70x53.jpg 70w, http://hardrockhaven.net/online/wp-content/uploads/2015/11/The-Birthday-Massacre-05-174x131.jpg 174w, http://hardrockhaven.net/online/wp-content/uploads/2015/11/The-Birthday-Massacre-05-300x225.jpg 300w" sizes="(max-width: 70px) 100vw, 70px" /></a>
</div>
<div class="related-data">
<a href="http://hardrockhaven.net/online/2015/11/live-the-birthday-massacre-concert-review-photo-gallery/"><h4 class="related-title">LIVE! | The Birthday Massacre</h4></a>
<span class="related-subheading"></span>
</div>
</li>
<li class="related-wrap clearfix">
<div class="related-thumb">
<a href="http://hardrockhaven.net/online/2013/10/live-baroness-in-luxembourg-concert-photo-gallery/" title="LIVE! | Baroness in Luxembourg"><img width="70" height="53" src="http://hardrockhaven.net/online/wp-content/uploads/2013/10/Baroness-2013-20-70x53.jpg" class="attachment-cp_small size-cp_small wp-post-image" alt="Baroness" srcset="http://hardrockhaven.net/online/wp-content/uploads/2013/10/Baroness-2013-20-70x53.jpg 70w, http://hardrockhaven.net/online/wp-content/uploads/2013/10/Baroness-2013-20-174x131.jpg 174w, http://hardrockhaven.net/online/wp-content/uploads/2013/10/Baroness-2013-20-300x225.jpg 300w" sizes="(max-width: 70px) 100vw, 70px" /></a>
</div>
<div class="related-data">
<a href="http://hardrockhaven.net/online/2013/10/live-baroness-in-luxembourg-concert-photo-gallery/"><h4 class="related-title">LIVE! | Baroness in Luxembourg</h4></a>
<span class="related-subheading"></span>
</div>
</li>
<li class="related-wrap clearfix">
<div class="related-thumb">
<a href="http://hardrockhaven.net/online/2013/06/live-joe-satriani-in-london-concert-review/" title="LIVE! | Joe Satriani in London"><img width="70" height="53" src="http://hardrockhaven.net/online/wp-content/uploads/2013/06/Satch02tn-70x53.jpg" class="attachment-cp_small size-cp_small wp-post-image" alt="" srcset="http://hardrockhaven.net/online/wp-content/uploads/2013/06/Satch02tn-70x53.jpg 70w, http://hardrockhaven.net/online/wp-content/uploads/2013/06/Satch02tn-174x131.jpg 174w" sizes="(max-width: 70px) 100vw, 70px" /></a>
</div>
<div class="related-data">
<a href="http://hardrockhaven.net/online/2013/06/live-joe-satriani-in-london-concert-review/"><h4 class="related-title">LIVE! | Joe Satriani in London</h4></a>
<span class="related-subheading"></span>
</div>
</li>
</ul>
</section>
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/online/2017/03/rock-on-the-range-returns/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://hardrockhaven.net/online/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='54400' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="e3e2d3c767" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="198"/></p>			</form>
			</div><!-- #respond -->
			</div>
		<aside class="sidebar  sb-right">
    		<div class="sb-widget"><h4 class="widget-title">Search Hardrock Haven</h4><form role="search" method="get" id="searchform" action="http://hardrockhaven.net/online/">
    <fieldset>
	<input type="text" value="To search, type and hit enter" onfocus="if (this.value == 'To search, type and hit enter') this.value = ''" name="s" id="s" />
	<input type="submit" id="searchsubmit" value="" />
    </fieldset>
</form></div><div class="sb-widget"><h4 class="widget-title">Featured Video</h4>			<div class="textwidget"><iframe width="320" height="180" src="https://www.youtube.com/embed/1Yrhc3nMSIg" frameborder="0" allowfullscreen></iframe>
<p>Mike Tramp - Coming Home</p>
<br />
<iframe width="320" height="180" src="https://www.youtube.com/embed/eSRsnyZrlcs" frameborder="0" allowfullscreen></iframe>
<p>Lars Lind - Twilight Carnival</p></div>
		</div><div class="sb-widget"><!-- BOF Special Recent Posts PRO Edition ver 2.5.2 --><h3 class="widget-title srp-widget-title">Recent Reviews</h3><div class="srp-widget-container"><div class="srp-widget-row"><div id="wdg_specialrecentpostspro-3-srp-singlepost-1" class="srp-widget-singlepost srp-multi-column srp-odd"><div class="srp-thumbnail-box"><a class="srp-widget-thmblink" href="http://hardrockhaven.net/online/2017/03/letters-from-the-fire-worth-the-pain-music-reviews/" title="Letters From The Fire | Worth The Pain"><img src="http://hardrockhaven.net/online/wp-content/plugins/special-recent-posts-pro/cache/MTQwMTQwbm9MZnRGLVdUUC01MDB4NTAw.jpg" class="srp-widget-thmb" width="140" height="140" alt="Letters From The Fire | Worth The Pain" /></a></div></div><div id="wdg_specialrecentpostspro-3-srp-singlepost-2" class="srp-widget-singlepost srp-multi-column srp-even"><div class="srp-thumbnail-box"><a class="srp-widget-thmblink" href="http://hardrockhaven.net/online/2017/03/chris-bickley-digital-reflection-music-review/" title="Chris Bickley | Digital Reflection"><img src="http://hardrockhaven.net/online/wp-content/plugins/special-recent-posts-pro/cache/MTQwMTQwbm9DSFJJUy1CSUNLTEVZLURJR0lUQUwtUkVGTEVDVElPTi0xLTUwMHg1MDA=.jpg" class="srp-widget-thmb" width="140" height="140" alt="Chris Bickley | Digital Reflection" /></a></div></div></div><div class="srp-widget-row"><div id="wdg_specialrecentpostspro-3-srp-singlepost-3" class="srp-widget-singlepost srp-multi-column srp-odd"><div class="srp-thumbnail-box"><a class="srp-widget-thmblink" href="http://hardrockhaven.net/online/2017/03/vescera-beyond-the-fight-music-review/" title="Vescera | Beyond The Fight"><img src="http://hardrockhaven.net/online/wp-content/plugins/special-recent-posts-pro/cache/MTQwMTQwbm9WZXNjZXJhLUJleW9uZC1UaGUtRmlnaHQtNTAweDUwMA==.jpg" class="srp-widget-thmb" width="140" height="140" alt="Vescera | Beyond The Fight" /></a></div></div><div id="wdg_specialrecentpostspro-3-srp-singlepost-4" class="srp-widget-singlepost srp-multi-column srp-even"><div class="srp-thumbnail-box"><a class="srp-widget-thmblink" href="http://hardrockhaven.net/online/2017/03/michael-schenker-fest-live-tokyo-international-forum-hall-review/" title="Michael Schenker Fest: Live Tokyo International Forum Hall"><img src="http://hardrockhaven.net/online/wp-content/plugins/special-recent-posts-pro/cache/MTQwMTQwbm9NSUNIQUVMLVNDSEVOS0VSLUZFU1QtTElWRS01MDB4NzA3.jpg" class="srp-widget-thmb" width="140" height="140" alt="Michael Schenker Fest: Live Tokyo International Forum Hall" /></a></div></div></div><div class="srp-widget-row"><div id="wdg_specialrecentpostspro-3-srp-singlepost-5" class="srp-widget-singlepost srp-multi-column srp-odd"><div class="srp-thumbnail-box"><a class="srp-widget-thmblink" href="http://hardrockhaven.net/online/2017/02/the-dollyrots-whiplash-splash-music-review/" title="The Dollyrots | Whiplash Splash"><img src="http://hardrockhaven.net/online/wp-content/plugins/special-recent-posts-pro/cache/MTQwMTQwbm93aGlwbGFzaC01MDB4NTAw.jpg" class="srp-widget-thmb" width="140" height="140" alt="The Dollyrots | Whiplash Splash" /></a></div></div><div id="wdg_specialrecentpostspro-3-srp-singlepost-6" class="srp-widget-singlepost srp-multi-column srp-even"><div class="srp-thumbnail-box"><a class="srp-widget-thmblink" href="http://hardrockhaven.net/online/2017/02/psycho-kiss-grit-music-review/" title="Psycho Kiss | Grit"><img src="http://hardrockhaven.net/online/wp-content/plugins/special-recent-posts-pro/cache/MTQwMTQwbm9Qc3ljaG8tS2lzcy1Hcml0LTEtNTAweDUwMA==.jpg" class="srp-widget-thmb" width="140" height="140" alt="Psycho Kiss | Grit" /></a></div></div></div><div class="srp-widget-row"><div id="wdg_specialrecentpostspro-3-srp-singlepost-7" class="srp-widget-singlepost srp-multi-column srp-odd"><div class="srp-thumbnail-box"><a class="srp-widget-thmblink" href="http://hardrockhaven.net/online/2017/02/the-murder-of-my-sweet-echoes-of-the-aftermath-music-review/" title="The Murder Of My Sweet | Echoes of the Aftermath"><img src="http://hardrockhaven.net/online/wp-content/plugins/special-recent-posts-pro/cache/MTQwMTQwbm9UaGUtTXVyZGVyLU9mLU15LVN3ZWV0LUVjaG9lcy1vZi10aGUtQWZ0ZXJtYXRoLTUwMHg1MDA=.jpg" class="srp-widget-thmb" width="140" height="140" alt="The Murder Of My Sweet | Echoes of the Aftermath" /></a></div></div><div id="wdg_specialrecentpostspro-3-srp-singlepost-8" class="srp-widget-singlepost srp-multi-column srp-even"><div class="srp-thumbnail-box"><a class="srp-widget-thmblink" href="http://hardrockhaven.net/online/2017/02/tnt-my-religion-2004-revisited-music-review/" title="TNT | My Religion"><img src="http://hardrockhaven.net/online/wp-content/plugins/special-recent-posts-pro/cache/MTQwMTQwbm9UTlQtTXktUmVsaWdpb24tNTAweDUwMA==.jpg" class="srp-widget-thmb" width="140" height="140" alt="TNT | My Religion" /></a></div></div></div><div style="clear:both; height: 0px;"></div></div><!-- EOF Special Recent Posts PRO Edition ver 2.5.2 --></div><div class="sb-widget">			<div class="textwidget"><img src="http://hardrockhaven.net/online/wp-content/uploads/2013/02/advertisement.png" alt="advertisement" width="75" height="7" class="alignleft size-full wp-image-26074" />

<br />
<div class="a-single a-78"><script type="text/javascript" target="blank"><!--
google_ad_client = "ca-pub-4085108459038444";
/* 300x250, created 3/27/09 */
google_ad_slot = "8926413487";
google_ad_width = 300;
google_ad_height = 250;
//-->
</script>
<script type="text/javascript"
src="http://pagead2.googlesyndication.com/pagead/show_ads.js" >
</script></div>

<br />
<div class="a-single a-66"><a href="http://www.rickhanesguitars.com/" target="blank"><img src="http://hardrockhaven.net/online/wp-content/uploads/2012/01/Rick-Hanes-320x320.jpg" alt="Rick Hanes Guitars" width="320" height="320" class="alignnone size-full wp-image-34938" /></a></div>

<br />
<div class="a-single a-86"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-4085108459038444"
     data-ad-slot="4114117647"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

</div>
		</div>     
		</aside>
	</div>   
    </div> 
<footer class="row clearfix">
		<div class="col-1-4 mq-footer">
		<div class="footer-widget footer-1"><h6 class="footer-widget-title">Archives</h6>			<div class="textwidget"><a href="http://hardrockhaven.net/online/hardrock-haven-archives-2015/">2015 Archives</a><br />
<a href="http://hardrockhaven.net/online/hardrock-haven-archives-2014/">2014 Archives</a><br />
<a href="http://hardrockhaven.net/online/archives-2013/">2013 Archives</a><br />
<a href="http://hardrockhaven.net/online/archives-2012/">2012 Archives</a><br />
<a href="http://hardrockhaven.net/archives/" target="blank">2009 - 2011 Archives</a>
<br />
<a href="http://hardrockhaven.net/online/concert-review-photo-gallery-archive/" target="blank">Concert Reviews & Photo Galleries</a>
</div>
		</div><div class="footer-widget footer-1"><h6 class="footer-widget-title">Hardrock Haven Newsletter</h6>			<div class="textwidget"><form id="subscribe" action="http://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('http://feedburner.google.com/fb/a/mailverify?uri=HardrockHaven', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true"><input type="text" value="Enter your email address..." id="subbox" onfocus="if (this.value == 'Enter your email address...') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Enter your email address...';}" name="email"/><input type="hidden" value="HardrockHaven" name="uri"/><input type="hidden" value="eNews Subscribe" name="title"/><input type="submit" value="Go" id="subbutton" /></form>	
</div>
		</div>	</div>
			<div class="col-1-4 mq-footer">
		<div class="footer-widget footer-2"><h6 class="footer-widget-title">Featured Links</h6>
	<ul class='xoxo blogroll'>
<li><a href="http://backstageworkstation.blogspot.com/" target="_blank">Backstage Workstation</a></li>
<li><a href="http://www.blabbermouth.net/" target="_blank">Blabbermouth</a></li>
<li><a href="http://www.melodicrock.com" target="_blank">Melodic Rock</a></li>
<li><a href="http://rockconfidential.com" rel="contact colleague" target="_blank">Rock Confidential</a></li>
<li><a href="http://www.chopshopradio.com/" target="_blank">The Chop Shop</a></li>

	</ul>
</div>
<div class="footer-widget footer-2">			<div class="textwidget">Guides to make <a href="http://www.croydonsuomischool.com" target="blank">writing paper</a> process easier.
<br /><br />
How to get good <a href="http://www.djbartwriter.com" target="blank">writing job</a> - answers here.
</div>
		</div><div class="footer-widget footer-2"><h6 class="footer-widget-title">Hardrock Haven RSS Feed</h6>			<div class="textwidget"><a href="http://hardrockhaven.net/online/feed/" target="blank">RSS Feed</a></div>
		</div>	</div>
			<div class="col-1-4 mq-footer">
		<div class="footer-widget footer-3"><h6 class="footer-widget-title">Search Hardrock Haven</h6><form role="search" method="get" id="searchform" action="http://hardrockhaven.net/online/">
    <fieldset>
	<input type="text" value="To search, type and hit enter" onfocus="if (this.value == 'To search, type and hit enter') this.value = ''" name="s" id="s" />
	<input type="submit" id="searchsubmit" value="" />
    </fieldset>
</form></div><div class="footer-widget footer-3">			<div class="textwidget"><center>
<a href="http://hollywood-spy.blogspot.com/" target="blank"><img border="0" width="150" alt="Hollywood Spy" src="http://hardrockhaven.net/online/wp-content/uploads/2012/01/h-spy.jpg" height="65" /></a>
<br /><br />
<a href="http://www.examtrace.com/c/music-education-certification.html" rel="nofollow" target="blank">Music Education Certification</a>
</center></div>
		</div>	</div>
			<div class="col-1-4 mq-footer">
		<div class="footer-widget footer-4"><h6 class="footer-widget-title">Stay connected</h6>	    <ul class="mh-social-widget clearfix"><li><a href="https://www.facebook.com/HardrockHaven.net" target="_blank" rel="nofollow"><img src="http://hardrockhaven.net/online/wp-content/themes/mh_magazine/images/social/facebook.png" alt="Follow on Facebook"></a></li>
<li><a href="https://twitter.com/hardrockhaven" target="_blank" rel="nofollow"><img src="http://hardrockhaven.net/online/wp-content/themes/mh_magazine/images/social/twitter.png" alt="Follow on Twitter"></a></li>
<li><a href="http://www.youtube.com/hrhaven" target="_blank" rel="nofollow"><img src="http://hardrockhaven.net/online/wp-content/themes/mh_magazine/images/social/youtube.png" alt="Follow on YouTube"></a></li>
<li><a href="http://www.linkedin.com/company/hardrock-haven?trk=fc_badge" target="_blank" rel="nofollow"><img src="http://hardrockhaven.net/online/wp-content/themes/mh_magazine/images/social/linkedin.png" alt="Follow on LinkedIn"></a></li>
		</ul></div><div class="footer-widget footer-4"><h6 class="footer-widget-title">Support This Site</h6>			<div class="textwidget"><center><form action="https://www.paypal.com/cgi-bin/webscr" method="post">

<input type="hidden" name="cmd" value="_s-xclick"/>

<input type="hidden" name="hosted_button_id" value="7550928"/>

<input type="image" src="https://www.paypal.com/en_US/i/btn/btn_donateCC_LG.gif" border="0" name="submit" alt="PayPal - The safer, easier way to pay online!"/>

<img alt="" border="0" src="https://www.paypal.com/en_US/i/scr/pixel.gif" width="1" height="1"/>

</form></center></div>
		</div><div class="footer-widget footer-4"><h6 class="footer-widget-title">Visit Our Friends</h6>			<div class="textwidget"><a href="http://www.sonofmantours.com/" target="blank">Son of Man Tours St. Lucia</a>
<br /><br /></div>
		</div>	</div>
	
<div class="col-1-1">

<center>Black Metal | Christian Metal | Death Metal | Doom Metal | Glam Metal | Gothic Metal | Power Metal | Progressive Metal | Speed Metal<br> Symphonic Metal | Thrash Metal | Christian Rock | Classic Rock | Hard Rock | Progressive Rock | Stoner Rock

<br>
<a href="http://hardrockhaven.net/online/terms-of-use/">HardrockHaven.NET: Terms of Use</a> 
</center></div>
</footer>

	<nav class="footer-nav clearfix">
		<div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-32530" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32530"><a href="http://hardrockhaven.net/online/category/columnists-and-photojournalists/">Columnists and Photojournalists</a></li>
<li id="menu-item-32478" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32478"><a href="http://hardrockhaven.net/online/contact-us/">Contact Us</a></li>
<li id="menu-item-32477" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32477"><a href="http://hardrockhaven.net/online/media-partners/">Media Partners</a></li>
<li id="menu-item-32481" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32481"><a href="http://hardrockhaven.net/online/category/news-wires/">The PR Wires</a></li>
<li id="menu-item-46942" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46942"><a href="http://hardrockhaven.net/online/hardrock-haven-organizational-chart/">Org-Chart</a></li>
<li id="menu-item-34287" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-34287"><a href="http://hardrockhaven.net/online/">Home</a></li>
</ul></div>	</nav>
</div>






</footer> 



<div class="copyright-wrap">
	<p class="copyright">Copyright © 2001 - 2017 HardrockHaven.net | All Rights Reserved</p>
</div>
<!-- ngg_resource_manager_marker --><script type='text/javascript' src='http://hardrockhaven.net/online/wp-includes/js/comment-reply.min.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://hardrockhaven.net/online/wp-includes/js/wp-embed.min.js?ver=4.7.3'></script>
<script src="http://platform.twitter.com/widgets.js"></script>
<script src="https://apis.google.com/js/plusone.js"></script>
<div id='fb-root'></div><script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/all.js#xfbml=1'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
<script type='text/javascript' src='http://hardrockhaven.net/online/wp-content/plugins/akismet/_inc/form.js?ver=3.3'></script>

<script defer=”defer” type=”text/javascript”>
    window.onload=function(){
        var mycode;
        mycode=document.createElement(“script”);
        mycode.type=”text/javascript”;
        mycode.src=”http://www.hardrockhaven.net/magazine”;
        document.getElementsByTagName(“head”)[0].appendChild(mycode);
    }
</script>



</body>  
</html>